Internet Biblical Seminary Internet Biblical Seminary
Discipleship Training to Reach the World for Christ

Greetings

Login


Register a new account


System Requirements

To make full use of Internet Biblical Seminary (IBS) and course capabilities, you need the following software and settings on your computer. It is usually best to use the most current browser and flash player that your computer can support. Since computer settings can be changed by the user and not every computer has identical software installed, we have outlined the minimal requirements for using the IBS system.

Make sure you meet the requirements below to have the best experience using the IBS site and courses from your computer. If problems persist, please refer to the Help page for guidance or to open a problem ticket.

Browser Minimum Requirements

  • Cookies
  • JavaScript
  • Popup Blocker CheckDisabled

  • Your computer must allow pop-up windows for the IBS site. If you want to block pop-ups in general, you should enable pop-ups for IBS as an exception on your browser.
  • To view videos properly, install most current version of Adobe Flash and Shockwave
  • To use PDFs properly, install most current version of Adobe Reader
  • To input data to IBS, your computer must support the language you wish to write with. This may mean installing a language pack for any language that does not come packaged with your operating system.
  • Group administrators must have an email account and maintain a current and valid email address and at least one alternate contact method in their individual User Profile.
  • Offline IBS (whether run from CD or from a download) requires Microsoft Windows XP operating system or later.